Forum: help-de

Monitor Forum | Start New Thread Start New Thread
RE: Kleopatra mit Administratorrechten installiert [ Reply ]
By: Bernhard Reiter on 2021-05-21 06:35
[forum:7896]
Hallo!

Georg, wenn ich Dein Bildschirmfoto richtig deutet, dann ist der Nutzer dort "Administrator".
Kannst Du mal probieren, einen anderen Nutzer anzulegen, der nicht Administrator ist und Kleopatra mit dem zu starten? Als Test. Damit sollte es gehen.

Danke auch für die anderen Hinweise, auf Installationsort und Prozessrechte, ich denke die können ebenso bei der Analyse helfen.

Viele Grüße,
Bernhard

RE: Kleopatra mit Administratorrechten installiert [ Reply ]
By: Markus Massing on 2021-05-20 12:43
[forum:7894]
Moinsen@all

in welchen Ordner wird GPG denn installiert?
Wir verteilen hier im Netzwerk die Software und geben dabei den Installationspfad "C:\Programme (x86)\GPG4Win" mit an. Das klappt wunderbar.
Wenn ich mich recht erinnere installiert es sich ohne Pfadangabe in %USERPROFILE%\Appdata\Roaming was natürlich problematisch ist weil das dann das Profil des Adminusers ist wo auch NUR er dann Rechte drauf hat.

RE: Kleopatra mit Administratorrechten installiert [ Reply ]
By: C C on 2021-05-20 12:33
[forum:7893]
Servus mitanand,

bei der Analyse von Rechteproblemen hat mir immer der Einsatz von ProcessMonitor und/oder ProcessExplorer (https://docs.microsoft.com/de-de/sysinternals/) fast immer weiter geholfen. Der Process Monitor zeichnet alle Operationen mit Status auf, mit Process Explorer kriegt man die effektiv gesetzten Rechte raus.

CC

RE: Kleopatra mit Administratorrechten installiert [ Reply ]
By: Georg Landmann on 2021-05-20 12:15
[forum:7892]

Benutzerkonto.jpg (3) downloads
Servus Bernhard

Ich bin jetzt nicht sicher, ob du die Rechte für den Benutzer oder dem Verzeichnis meinst.
Ich kann leider nicht zwei Schreenshots hochladen.
Daher habe ich einen Screenshot vom Benutzerkonto gemacht.
Danach ist das Konto mit Adminrechten ausgestattet.

LG Georg

RE: Kleopatra mit Administratorrechten installiert [ Reply ]
By: Bernhard Reiter on 2021-05-20 09:17
[forum:7891]
Hallo Georg,
kannst Du mir genauer sagen, mit welchen Rechten das Konto ausgestattet ist,
mit dem Du Kleopatra startest?

(Weil das sollte das Entscheidende sein. Also Kleo **nicht** mit Adminrechten starten.)

Die 3.1.14 zu verwenden ist nicht optimal, kann aber übergangsweise gehen.
(Die 3.1.15 hat ein paar wichtige Verbesserungen.) 3.1.16 kommt aber auch bald.

Gruß,
Bernhard

RE: Kleopatra mit Administratorrechten installiert [ Reply ]
By: Georg Landmann on 2021-05-20 07:09
[forum:7890]
Servus Bernhard

Vielen Dank für die Rückmeldung. In dem Fall liegt das "Problem" wohl nicht an der Installation mit Adminrechten.

Ich habe jedenfalls den Hinweis umgesetzt und entsprechend neu installiert. Vorher natürlich deinstalliert und den PC neu gestartet.

Leider bricht Kleopatra nach der Neuinstallation mit der gleichen Fehlermeldung ab.

Nun habe ich die Version 3.1.5 wieder deinstalliert, neu gestartet und wieder die Version 3.1.4 installiert.

Dann kam ich nach der Installation der V3.1.4 doch wieder auf die Idee wieder auf die V3.1.5 zu aktualisieren. Danach kam wieder die bekannte Meldung und der Startabbruch von Kleopatra.

Irgendwo müsste in dem Fall in Windows die Information hinterlegt sein, dass Kleopatra mit Adminrechten gestartet werden muss. Aber dazu finde ich in Windows nicht.

Jetzt bin ich wieder zu der Version 3.1.4. zurück

Möglicherweise bringt eine Änderung in der nächsten Version den erhofften Erfolg.

Vielen Dank nochmals für den Lösungsansatz.

LG Georg


RE: Kleopatra mit Administratorrechten installiert [ Reply ]
By: Bernhard Reiter on 2021-05-19 07:32
[forum:7889]
Servus Georg,

der empfohlene Weg ist Gpg4win als Admin (mit Admin-Rechten) zu installieren
und als Konto ohne Admin-Rechte laufen zu lassen. Das sollte gehen, bitte probiere
es nochmal.

Trotzdem wird die Meldung in der nächsten Version in eine Warnung umgewandelt.
Einige Details dazu findest Du auf Englisch hier: https://wiki.gnupg.org/Gpg4win/RunAsUser

Viele Grüße,
Bernhard



Kleopatra mit Administratorrechten installiert [ Reply ]
By: Georg Landmann on 2021-05-18 16:52
[forum:7888]
Servus an Alle

Ich habe leider GPG4Win als Administrator installiert. Danach bekam ich beim Starten von Kleopatra folgende Meldung:
__________________________________________________________
Kleopatra kann nicht als Administrator ausgeführt werden ohne Dateiberechtigungen im GnuPG Datenordner zu beschädigen.

Um Zertifikate für andere Nutzer zu verwalten tun Sie dies Bitte mit einem Nutzeraccount und kopieren anschließend das 'AppData\Roaming\gnupg' Verzeichnis mit den korrekten Dateirechten.
__________________________________________________________
Danach habe ich alles wieder deinstallliert, neu gestartet und dann wieder neu ohne "Administratorrechte" installiert.

Es änderte sich leider nicht mehr an dem vorigen Malheur.

Auch das komplette Löschen der Verzeichnisse und der Einträge in der Registry etc. haben das Problem nicht beheben können.

Tipps aus den Weiten des Internets haben mich auch nicht weitergebracht.

Als Windows-Version ist bei mir die Version 10. Rev. 19043.985 am werkeln.

Bei gpg4win handelt es sich um die Version 3.1.15.
Der PC läuft über meinen Server mit Windows Server 2019 und ist an der Dmäne angemeldet.

Die Vorgängerversion von gpg4win lief super.
Bis ich eben beim Update mit Administratorrechten installiert habe.....

Die aktuelle Installation (Version 3.1.15) ist normal installiert und läuft nicht als portable Version.

Bei der Installallation übernehme ich immer die Vorgaben der Standartverzeichnisse.

Ich hoffe, dass ihr mir mit Informationen zur Problemlösung weiterhelfen könnt.

LG Georg