Forum: help-de

Monitor Forum | Start New Thread Start New Thread
RE: Gesendete signierte E-Mails leer [ Reply ]
By: Andre Heinecke on 2021-04-12 10:29
[forum:7862]
Hi,

ich denke das kann wirklich an diesen PR_SECURITY_FLAGS liegen. Die Warnmeldung dazu war ja nicht umsonst, Outlook behandelt solche mails anders und wir sehen nicht mehr richtig die Daten.

Also wenn Outlook glaubt es würde verschlüsseln oder signieren wird eine Mail anders behandelt. Das tritt sogar auf wenn du in Outlook verschlüsseln und signieren einmal anklickst und dann wieder abwählst. Zumindest dafür haben wir aber einen workaround.

Am besten wäre natürlich eine Anleitung wie man das reporduziert, aber ich spiele bei mir mal mit dem Trust Center und "immer signieren" und so rum um zu versuchen da etwas zu finden.

Ansonsten würde vielleicht noch ein log mit +data debugging von einer solchen Mail helfen. Da könnte ich eventuell sehen wo die Daten verloren gehen.

Schöne Grüße,
Andre

RE: Gesendete signierte E-Mails leer [ Reply ]
By: Bernhard Reiter on 2021-04-12 10:14
[forum:7860]
Hallo Joachim,

Danke für die ausführliche Analyse!
(So etwas ist immer nützlich, weil es hilft den Einsatz von Outlook und die Ausrprägung von Datenstrukturen in der Breite zu verstehen.)

Gruß,
Bernhard

RE: Gesendete signierte E-Mails leer [ Reply ]
By: Joachim Reichert on 2021-04-09 16:15
[forum:7859]
Hallo allerseits.
Ein ähnliches Problem hatte mein Chef auch. Gesendete wie auch empfangene Mails (verschlüsselt + signiert) waren inhaltsleer. Anhänge wurden aber angezeigt und entschlüsselt. Was beim Empfänger ankam, weiß ich nicht zu sagen.

Da mein Chef ein Problem mit einem falsch gesetzten Flag in PR_PROPERTY_FLAGS hatte (siehe https://wald.intevation.org/forum/forum.php?thread_id=2276&forum_id=84), habe ich mit OutlookSpy herumexperimentiert.

Ergebnis:
Bei manchen Mails war PR_SECURITY_FLAGS überhaupt nicht gesetzt, bei anderen auf den Wert 0, also eigentlich richtig.

Versuchsweise habe ich trotzdem (nochmal) PR_SECURITY_FLAGS auf 0 gesetzt. Das scheint irgendetwas resettet zu haben. Danach waren die Mails wieder lesbar (nach Schließen und erneutem Öffnen).

Ich vermute, dass dieses Verhalten mit einem vermurksten Outlook-Update in Zusammenhang steht, da dieses Phänomen bei mir zunächst nicht vorhanden war. Möglicherweise wurde das entsprechende Update bei mir erst später eingespielt, da ich wesentlich seltener im Büro bin als mein Chef. Dann aber hatte ich diesen Effekt auch.
Hier im Home Office bin ich jedoch komplett verschont geblieben (anderer Update-Channel?)

Ich weiß nicht, ob unser Problem mit dem hier geschilderten identisch ist, aber vielleicht hilft es jemandem weiter.

Herzliche Grüße
Joachim

RE: Gesendete signierte E-Mails leer [ Reply ]
By: Erik Friedrich on 2021-04-09 15:21
[forum:7857]
Gab es hierzu schon eine Lösung?

Ich habe einen ähnlichen Fehler. Eine Antwort oder Weiterleitung wird verschlüssselt und signiert. Gesendet wird aber nur eine leere E-Mail. Der Fehler lässt sich leider nicht gezielt reproduzieren, tritt aber 1 bis 2 mal täglich auf.

RE: Gesendete signierte E-Mails leer [ Reply ]
By: Andre Heinecke on 2020-10-07 12:35
[forum:7477]

OpenPGP key 0xF462B6B1 (5) downloads
Mir ist da bisher nichts bekannt. Vermutung bei sowas sind häufig wechselwirkungen mit anderen plugins.

Zur weiteren Analyse würde mir nur ein log und eine Mail helfen. Bitte mal unter Fehlersuche logging aktivieren mit Log Stufe +Outlook API Aufrufen
und mit der Markeriung: + Mail Inhalten

Dann auf dem Rechner bitte eine Mail signiert schreiben an aheinecke@gnupg.org wie du es sonst machen würdest und Sie danach einmal unter versendete Nachrichten betrachten.

Das Log kannst du mir gerne auch verschlüsselt schicken da es z.B. deine E-Mail addresse auch enthalten wird. Ich gehe damit natürlich vertraulich um. Mein OpenPGP Key ist im Anhang.

Gesendete signierte E-Mails leer [ Reply ]
By: Bernd Leutenecker on 2020-10-07 12:29
[forum:7476]
Hallo!

Leider musste ich erst nachträglich feststellen, dass seit ca. letzter Woche von mir verschickte mit meinem GPG-Key signierte E-Mails leer sind.
Wo könnte ich evtl. im Zuge der Anpassungen aufgrund anderer Probleme evtl. etwas verstellt haben, was sollte ich prüfen?
Auf einem anderen Rechner habe ich dieses Problem zum Glück nicht.

Jedenfalls ärgerlich - ich muss jetzt versuche, mich an alle vom betroffenen Rechner verschickten signierten E-Mail-Inhalte zu erinnern und diese nochmals schreiben.

Eine Kontextoption ("dauerhaft entschlüssen" o. ä.) finde ich nicht mehr - was aber eben daran liegen könnte, dass es gar keine Inhalte in den E-Mails mehr gibt.
In einer betroffenen leeren E-Mail (die ich über Bcc auch an mich, aber ohne jegliche Fehlermeldung o. ä. gesandt hatte), ist das GpgOl-Icon lila mit einem weißen Fragezeichen und dem Text "Unsicher". Bleibe ich etwas länger auf dem Icon (ich war bisher dafür zu ungeduldig; klicken bringt diese Info nicht) erscheint diese Meldung:
"Unsichere Nachricht

Sie können nicht sicher sein wer die Nachricht gesendet, modifiziert oder während der Übertragung gelesen hat.

Die Nachricht ist signiert aber die Überprüfung schlug fehl mit:
No data"

Sehr ärgerlich ...

Grüße

Bernd Leutenecker