Forum: help-en

Monitor Forum | Start New Thread Start New Thread
RE: Stop Kleopatra from intercepting PGP export from MFT?? [ Reply ]
By: Mark W on 2020-05-10 21:13
[forum:7182]
I have another program that associated itself with PGP Keys (PowerArchiver) as it can use PGP to encrypt archives. I had to set those extensions to Kleopatra as well.

RE: Stop Kleopatra from intercepting PGP export from MFT?? [ Reply ]
By: Bernhard Reiter on 2020-05-08 11:43
[forum:7178]
Roger,
good to know that things are working for you know. :)

Thanks for reporting back!

Best,
Bernhard

RE: Stop Kleopatra from intercepting PGP export from MFT?? [ Reply ]
By: Roger Harman on 2020-05-07 22:39
[forum:7175]
The MFT is GoAnywhere from HelpSystems (formerly Linoma Software)

What I found was that Kleopatra put itself as the associated application for .asc files. Once I changed that, I was back in business. Interestingly, it left Adobe for the .pgp extension.

I should have thought at file associations but it didn't click that a simple download via the browser (Chrome) would launch an app to handle the file.

Thanks for the nudge.

RE: Stop Kleopatra from intercepting PGP export from MFT?? [ Reply ]
By: Andre Heinecke on 2020-05-07 08:03
[forum:7174]
But I would also be interested which tool it is that roger is using. Always interesting to hear of other OpenPGP implementations.

RE: Stop Kleopatra from intercepting PGP export from MFT?? [ Reply ]
By: Bernhard Reiter on 2020-05-07 08:01
[forum:7173]
Hi Andre,
thanks for adding to my answer and setting things straight. :)
Bernhard

RE: Stop Kleopatra from intercepting PGP export from MFT?? [ Reply ]
By: Andre Heinecke on 2020-05-07 07:49
[forum:7172]
Hi Bernhard,

The file type registration is not done by GpgEX but done by installing Kleopatra or GPA. File type registration basically means that they get an icon and can be double clicked.

That means that by default *.pgp files and *.asc and *.gpg is opened with Kleopatra.

What I think happens here is that the other tool writes a file and then uses ShellOpen to open that file. Before Gpg4win was installed that would probably open it with Notepad (straight to ASCII) but now it is opened with Kleopatra.

What you can do to fix that is to right click that file -> Open with -> Select Notepad and check "Always use this program".

Regards,
Andre

RE: Stop Kleopatra from intercepting PGP export from MFT?? [ Reply ]
By: Bernhard Reiter on 2020-05-07 07:23
[forum:7169]
Hi Roger,

can you be more specific what kind of MFT product you have and what is happening in more detail?

As far as I know, the GpgEX extension for the Internet Explorer (which is the file browser) registers a few file types for the open action and this also affects the icons. However
I am unsure how this would be related to writing a file. The registration of file type can certainly be undone. You could also try to deinstall the GpgEx part of Gpg4win and see if it makes a difference.

Regards,
Bernhard

Stop Kleopatra from intercepting PGP export from MFT?? [ Reply ]
By: Roger Harman on 2020-05-06 23:35
[forum:7167]
I have an MFT product and when I try to export public keys, Kleopatra intercepts the export. I just want to go straight to ASCII like it did before I installed GPG4Win.

I have not found a setting to disable that. How can I stop Kleopatra from intercepting my export?

Thanks!!