Forum: help-en

Monitor Forum | Start New Thread Start New Thread
RE: No secret key Error message [ Reply ]
By: Bernhard Reiter on 2020-03-11 13:45
[forum:7093]
Hi Tony,

when you want to start completely fresh, you need to remove the personal data and configuration files of the crypto engine (GnuPG).

Usually this is under %APPDATA%\gnupg , just move it away.

The advanced way (for technicians) is to use the command line and see what the problem is, maybe there are still remains of the first key-pair.

Best Regards,
Bernhard

No secret key Error message [ Reply ]
By: Tony Rogers on 2020-03-10 15:49
[forum:7091]


The GPGME library returned an unexpected
error at gpafiledecryptop.c:538. The error was:

No secret key

This is either an installation problem or a bug in GPA.
GPA will now try to recover from this error.




I hope you can help. I installed GPA and decrypted my 1st message ok. I made a mistake by using an active email address linked to that key so to be safe, I decided to delete that key and start fresh.

Now when I try and decrypt any message I get the error message above. I have uninstalled, reinstalled switched to Kleopatra and even system restalled but still get the same error message.

Can anyone give me a newbie step by step process to fix this? I like using GPA as I find it easy to navigate.

Thanks for any help