Home
My Page
Projects
gpg4win

Forum: help-en

Monitor Forum | Start New Thread Start New Thread
RE: Outlook 2010 with Gpgol (Gpg4win 2.3.4) message decryption fails (SOLVED) [ reply ]
By: Joseph Kang on 2017-07-24 20:28
[forum:4996]
Just wanted to update anyone that came across this message that I solved my own problem.

I had gotten confused about which key I had sent to the other party in my email exchange. Once I added the correct private key into Kleopatra, I was able to successfully decrypt the messages I had received.

Outlook 2010 with Gpgol (Gpg4win 2.3.4) message decryption fails [ reply ]
By: Joseph Kang on 2017-07-24 17:00
[forum:4995]
Hi, I am completely new to using PGP with Outlook 2010 and I am having a terrible time trying to get encrypted messages from another party to decrypt. The error messages that Kleopatra outputs are too vague to be useful to me.

I have added the sender's public key to Kleopatra. The private key I added to identify our support group was generated with:

gpg (GnuPG) 2.0.14
libgcrypt 1.4.5

on a CentOS 6 system.

The message was sent directly to me (a different email address than that used to generate the private key).

When I attempt to open an encrypted message, the "Decrypt/Verify E-mail" window shows "Decryption Failed: Decryption Failed". Under "Show Details", I see:

Recipients:
- sender name (correspondence key)
- one unknown recipient.

Is the problem that the email address used for the public key used to encrypt the message (abc@foo.com) does not match the email address that the message was sent to (me@foo.com)?

If so, is there any way I can fix this on my end and decrypt these messages without having to ask the sender to resend using my personal key?

Thanks in advance!


This site is hosted by Intevation GmbH